Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2020 - 08:00 EDT
Scheduled
We will be making updates to our infrastructure during this time. Response times may be slower than usual but we do not anticipate any significant disruptions.
Posted Jul 22, 2020 - 09:24 EDT
This scheduled maintenance affected: API and Campaign Dashboard.